Parameter #1 does not contain array of filenames


I’m quite new Grav user so forgive me if following is trivial question:
after upgrading Grav from 1.6.19 to 1.7.3-rc3, I got following error when loading any page:

I updated Grav core + Admin and also Form plugin (to 4.0.1) successfully so atm have no clue what actually went wrong.

To improve the static analysis of Grav, its underlying dependency - Toolbox - was upgraded. Because of this, the old way of loading blueprints no longer applies it seems. Yet to find a fix though, but I’ve pinged Matias about it.


Some additional bits to clarify: same error occurs after clean 1.7.0-rc3 install too.

  1. If I switch “Frontend Page Type” to Flex Object (Experimental) on the Configuration-> System-> Experimental page, then whole admin page throws that error.

  2. Now, when I modify manually system.yaml file (pages: type: flex -> pages: type: page), then I am able to load the list of pages, but when clicking on single page, same error is displayed.


Same issue here. Following the thread to see when a fix is released.

The 1.7-branch contains a fix for this, but RC.4 has not been released yet. An issue is open on GitHub: