Anyone having issues with the admin panel after updating?

I suddenly cannot see the pages inside the admin panel. When I click on the pages to edit them they show an all white screen. Fifteen minutes earlier, this was possible. Can anyone help with this?

Hi @werdi

Is this a clean install or an existing site ?
Can you state the php and grav versions ?
Was it a working site that you have updgraded ?

With grav 1.7 a new model called flex-pages has been introduced.

If you run a test server , can you do a clean fresh install of grav, then copy your pages for the old site to this test grav and does the problem still occur ?

Hi @spamhater thanks for replying.

It’s an update on an existing site.

The PHP Version is called 7-73STABLE-STANDARD – it seems to be the highest available stable version from my provider

Grav Version is v1.7.14 - Admin panel Version is v1.10.14

I just updated the PHP version last week because I tried the Grav update and it forced me to. But then, I’m not sure it matches the requirements.

Yesterday I was working on the site as usual, when suddenly the pages stopped being visible on the admin panel. The site is fully rendered on the browser and I can edit pages in the HTML-files. The only pages that don’t seem to be affected are the modular pages.

I don’t run a test server, so I wouldn’t know how to do what you suggest.

Is there any other option besides this?

Is it possible to and your willing to copy and zip the user directory on the site and private message me with an upload link.

I can use my computer to create a test clean site based on your php and settings and then see how it displays on my computer or if you are a windows user, I can help you set up a testing server via wamp.net (a portable testing server on windows)

I presume you have a computer and see if anything looks really weird and figure out if it is a server issue or a grav issue.

Drop us a private message if you want to try and talk you through it or even doing a quick teamviewer remote session. I am more a windows guy with linux and unix as a fall back, but can point you in the right direction with mac.

I am sure we can get it sorted.

Thanks for offering. I will run a test server myself first.

Hi @werdi

Just been helping someone else in the forum and now identified and worked out the problem and reporting it to grav.

Its seems to be related to new child element off subfolder (page / folders) - so you can create a folder off page off the root ok, but anything below that the quirk is happening.

Its a multi level issue … and its only just started to happen, so probably due to the flex-object update.

https://discourse.getgrav.org/t/grav-1-7-add-weird-number-to-folder-numeric-prefix/17204/8

I am going to log it and they will have to produce a fix :slight_smile: so bare with and I will let you know what is going off !

Thanks for keeping in touch. That’s what I thought as well, that more people would start reporting this. Thanks!

@spamhater Is there any news on this topic?

@werdi As far as I know the folder issue was resolved about a week ago . Please see the link here

And the release of 2 days ago, will have this included. It was tested by myself and pamtbaau.

https://getgrav.org/ or update through the admin panel.

How did you get on with your clean test server ?

The only thing you will have to check is any numeric pages / folders are in a low numeric order, as if there is one of these high numbers 1000000 or 9999999, when adding additional page it will use these numbers + 1

Come back to us, if you need any more info

@spamhater Thanks for your reply. I just updated the Grav version to 1.7.16 and the admin panel to 1.10.16 – the issue persists. Is there something I’m missing? I didn’t run my test server, since an update seemed to be the solution.

Otherwise, is there any way to install an older version of the admin panel without the GPM or Terminal?

@spamhater By the way, I now cannot access first level pages anymore.

@werdi You can use this to rollback

Use the following format to download pre-packaged zips:
https://getgrav.org/download/TYPE/PACKAGE/VERSION

https://getgrav.org/download/core/grav-admin/1.7.14

Where TYPE can be:

  • core
  • plugins
  • themes

PACKAGE:

  • grav
  • grav-admin
  • grav-update
  • name of plugin or theme

VERSION:

  • E.g. 1.7.14

So that will allow you to select what version. There has not been any one else identified with the issue. It seems that there might be something pretty specific.

Again the option to zip your users folder up and upload it and I can have a better look. You could do with it really sorting otherwise you will find that you may be stuck on ‘that’ release.

I would always suggest installing to a fresh directory and then copy your user folder across, to avoid any file conflict.

Keep us informed
:slight_smile: