"Pages" missing from Admin on cloned instance

Hi! Long-time user, first-time caller.

I have a grav site, and I now wish to upgrade my theme. I’ve decided to make a copy of the site for development and testing my changes.

I have created a complete copy of my working grav folder to a new folder, and configured as necessary:

  • cp -r /srv/http/grav /srv/http/grav-dev
  • [configure webserver]
  • edit /srv/http/grav-dev/user/config/system.yaml:
    • change session name to reflect dev site

Hitting the dev site in the browser, I run into some issues:

  • a few plugins (that I had modified) complain of missing templates, so I disable them via the plugin’s xxx.yaml config.
  • The site front-end now works as expected, except my logo image is missing.
  • The admin side was an all white page complaining that flex-objects.html.twig can’t be found. After copying it from user/plugins/flex-objects/templates/flex-objects.html.twig to user/theme/xx/templates, the admin site loads.
  • On the admin side, everything seems to work fine, except for the Accounts and Pages sections are empty, rather than displaying my 80+ pages. The buttons to add new pages are absent as well.

I’ve also tried downloading the grav folder to my local environment, and eventually get the exact same results. There is nothing meaningful in the logs, nor are there server errors.

I’m sure I’m doing something boneheaded…

Thanks in advance!


I’ve figured it out. It turned out to be caused by either Leaflet or Leaflet Address plugins. Once disabled, no more issues with flex-objects or missing pages!

Others had suggested disabling other plugins, so I began the painstaking task of removing my plugins one by one until it un-broke!

Hope this helps someone else!