Hosting site online help!

Hi, i’m having issues and i’m pretty new to all this, so i don’t know how to go about this.

I’m trying to get my locally hosted site, online. I’ve tried uploading the site contents to where i’m hosting from (EasySpace) via FileZilla like i would with a Joomla site(minus database configuration). Everything transferred fine, but my website is just an empty page with no contents.

Is this how its supposed to be done? Help would be much appreciated.

Thanks.

There are a couple of ways to transferring all files that together make a Grav website to a remote server, in your case at EasySpace. Which method depends on technical possibilities (e.g. SSH access) and what method you’re comfortable with. Via ftp by means of FileZilla should work fine.
Can you be more specific? For instance what do you mean by empty page with no contents? Is it completely blank or is the menu etc. shown but without the actual page content of your markdown files. Also form which local directory are you transferring your files, to what remote server directory or path are you copying, etc.

http://www.thecabinetshop.co.uk
That is my site. If you’re seeing the same as me, it’s completely blank. Also i’m transferring the contents of the site folder in ‘htdocs’, to the ‘www’ folder after connecting to the ftp.

My process of getting Joomla sites online is the same, plus configuring the database, but if my understanding is correct, Grav’s database is held within the sites folder in, so i don’t need to configure any databases with the one held in EasySpace…?

Thanks

That’s not blank. That’s an error 500. Check your server logs. You can also edit user/config/system.yaml and set display.errors to true (though the error doesn’t appear to be Grav related just yet).

You are correct that you don’t need any database. Your site content lives in user/pages.

Sorry, i checked on a different browser and that was saying error 500. I’ve checked system.yaml and there doesn’t appear to me a display.errors. Sorry if i’m not following.

Thanks

Well if it was a true Grav error, you would get a different looking page. So it appears that your current problem is not related to Grav specifically. So definitely check your server error logs. To see actual stack traces of Grav errors, put the following in user/config/system.yaml:

errors:
  display: true

I’ve checked the server logs, and i’m not sure what i’m looking for. There’s a long list of stuff. Also, adding that appears to have not done anything. Apologies for not being much help.

Adding that won’t do anything yet because the error you’re getting is not Grav related. You need to look at your logs and do some googling to find out why the webserver is dying. It could be any number of causes depending on your configuration. If you have access to support, you could call EasySpace. There’s just not much we can do for you here without a lot more information.

Okay, I think I understand. I’ll do some more research/googling. Thanks for your help.

Good luck. If you do eventually start getting Grav errors, let us know. Those we can help with :slight_smile:

Take a look at this troubleshooting page: https://learn.getgrav.org/troubleshooting/internal-server-error
Especially the Rewritebase part and the Options -Indexes part.
Most of the time, I had 500 error problem due to file permission, so it might worth take a look at that too: https://learn.getgrav.org/troubleshooting/permissions

Hope it helps!

Paul, I didn’t have any luck with those. Thanks anyway.

I’ve spoken with my hosting provider and they’ve said:

As we’re able to upload and view a test file, it implies the problem is being caused by the coding or structure of your website.
Also
Here are the specs for the server you’re being hosted, please can you have a read over and let us know if this server is compatible for your site:
http://vhost15.yoursitepreview.net/info.php

I’ve looked through it, but i have absolutely no idea what i’m looking for there. Does anyone know if Grav is compatible with those specs?

Thanks.

oh, you are running PHP 5.4 and Grav needs at least php 5.5. This is something you should be able to modify from your host admin panel.

Yep, that was the issue. I’ve upgraded to the latest version now and it’s working!

Thanks for everyones help!

your /about seems to result in a #500 internal server error…