Admincontroller.php getting deleted by the server?


I have tried installing GRAV with Softaculous script through CPanel, and also manually ftping latest version but with no luck. Each time admincontroller.php dissapears or gets deleted? I have tried with the earlier version of the script (Nov 2016 from github) and that one stayed.

How to troubleshoot this, what could be the reason?


Must be something on the server doing this. Perhaps a security script? You might need to contact your hosting company.

Hi, I have the exact same behavior. Because of this, I can’t manage my blog anymore. This happen after the last update, at first I got the Security Token Invalid error. When I decided to came back to the older version (with a backup) I got this instead. I don’t know why this file is deleted automatically. Can you tell us what changed in the meantime to provoke a server to delete this file?

I don’t know what to tell to my hosting company… I want to have at least a little of information to help them to help me.


This was bugging me for a long time now, and I continue to search. It appears that the file is deleted automatically because of a mention of a symlink. So, I opened the file admincontroller.php, search for symlink, then at line 852, I found “isSymlink” => $gpm->grav->isSymlink(). I removed the line, then deleted the comma at the end of the line 851. I re-uploaded the file, and bam, everything (well, except I see 0 plugin and 0 theme when browsing the admin page, but in the backend, they are there and working…) now is working like a charm. I can login again and manage my blog like before.

I got clue from this post on stackoverflow: Since I have CPanel… I decided to try…

For now, this line is removed from the file. Did I broke something? Does this line can be “renamed” in something else, or a fix may be applied. From what I understand, the word “symlink” isn’t well received. Maybe it’s to avoid a backdoor, or a threat.

Anyway, I just wanted to let you know guys what was the cause of this “mysterious disappearance”.

More information here, It’s not working like a charm… the themes list and plugins list returned 0 elements. So I presume this line was used to “poke” those folders than count items and make links to them.

Also, if I want to change something in the system configuration, since I haven’t any themes (in the list) it use the theme defined in the system.yaml in the system folder to failback the missing entry in system.yaml from the user folder.

Does someone at GRAV can help with this ?