Site unavaliable after update 2022-10-07

Installed Grav 2022-09-28 on local server for evaluation purposes. Couldn’t make it work. 2022-10-04, tried it before deleting the install… was asking for a sign in (as expected) it was working! :person_shrugging: Trying it later again, had some error message, I hit refresh (browser) and it worked. :person_shrugging: Today 2022-10-07 (haven’t done anything except look so far) it said there was an update in the admin panel. Updated. Now root is Forbidden and admin does not exist. (I hadn’t backed up, yet :expressionless:) grav Logs are pure red from 10/4 and install date 9/28, noting today 2022-10-07. Much the same with Apache logs. Too many errors to list. Worked fine until the update (despite errors).

I’ve checked all the permissions, read all the solutions I could find. Reset all the permissions on all the folders (to be sure). Nothing Forbidden & Does not Exist.

Don’t really expect a solution, might be nice. Will try to install it again if I don’t hear back shortly, but with this disaster, will be relucted to go ahead with it (it’s my favorite choice among 18 candidates) - But if updating means I lose everything, something encouraging would be welcome.

Not sure what’s happening, but quite often I find installation messed up if updated from UI, so in such case I usually run

php bin/gpm update

And this fixes it.
Strangely this happens only on local env

Thank you @Karmalakas I’ve just spent xx minutes with CLI’s. cmd, powershell, laragon terminal, Composer version 2.4.1 2022-08-20 11:44:50, php.exe It’s sincerely been a while but I can’t make any CLI do anything listed on any grav related site, including php bin/gpm update. (Composer nicely updated things I didn’t know I had.)
The average response to php bin/gpm update is ‘FATAL: Must be run from ROOT directory of Grav!’ (running from the root directory, or ‘Could not open input file: bin/gpm’ (running from bin).

I am frustrated and tired. I might be missing something. I did update and nothing is working since. I’m a bit confused at this:…

PROBLEM 2 (possibly)
In the admin panel I upgraded from (http://localhost/thinkonit/admin/config/system) I clicked on ‘admin’ and it changed dir to http://localhost/thinkonit/admin/config/system (404 Not Found) There is no admin Directory, nor is there one in the zip file for I was just starting to evaluate grav, so can’t remember if grav created those dirs after I signed in initially. If it did, they’re gone now.

I downloaded, copied it over the old install.
λ php bin/gpm update

GPM Releases Configuration: Stable

Nothing to update.
Logged on, no issues. I’m still confused. Browser says it’s on http://localhost/thinkonit/admin/accounts/users/aegiswiz. Explorer doesn’t show any admin dir (veiwing all hidden files). There is one under “users”. No matter. It works, I can evaluate it. Thanks so much for everyone who helped! I don’t recommend updating from admin panel but that’ll likely be fixed before long.