Problem with Form

I still have problems with the form plug-in on an one page skeleton with big-picture theme.
After clearing the cache it works for a while but stops working after a while. Instead of triggering the thank-you page and sending the mail, it justs forward to

I can force the plug-in to work for a while clearing the cache in the admin.

At first I assumed that it is a problem with the 301 redirect rule in the webserver configuration. But it isn’t.

Also it seems not to be a local cookie problem. Clearing locals device caches

The plug-in is up to date

hmm, I see an error right now: It ssems to be related with “NONCE_NOT_VALIDATED”

I’m linking to the contact form with

what version of Grav and Form plugin are you running? Can you also try setting gpm: releases: testing and updating to latest RC releases as I’ve made some changes in this area in the last couple of RC releases of Grav +_ Form plugins.

Thank you for your reply!
Isn’t it to high risk setting to testing because of damaging functionality?

Not really, just backup your site first. it’s where we put our fixes and improvements first before releasing an actual release. If no one tests, then we might release code that is not in fact fixed at all!

OK, I’ ll try it today :thumbsup:

I upgraded to testing including all dependencies.
Upgrade process worked like a charm.
Then I cleared the cache within the admin.

On Desktop (Firefox) all messages have been sent.
Then I tried my mobile device with chrome which didn’t work (neither with cleared local cache and cookies).
I tested Desktop again and it still worked. I haven’t got any Error messages yet.

I’ m rebooting the mobile device right now for another testing. EDIT: That doesn’t work

Hours later I just have tried it on the Desktop where it had been running at least. But also on the Desktop It doesn’t work anymore and just redirects to
I 'm pretty sure I coukld get it work temporarily with clearing the Cache via the admin.

Do you have any news?

If you are using a form in a modular page, you should set that particular modular page to disable the cache with: cache_enabled: false in the modular page frontmatter. Try that.

Yes, I’m using the big picture one-page skeleton which has the form at the end of the skeleton. I will try that. Thank you!

I have just tested my mobile device. It still doesn’t work even after clering private data.
I have enabled zlib output compression via php.ini and deflate via htaccess.
My form frontmatter is this:
title: Kontakt
heading: 'Schreiben Sie mir.'
cache_enabled: false