Trouble getting form to post using Guestbook

I am using the Guestbook plugin. I have added the plugin to my page, using the standard frontmatter from the plugin repo readme. I have added my captcha keys and when I submit a form, I get the validation message:

“Oops there was a problem, please check your input and submit the form again.”

My input is fine and my captcha is working fine. I am not getting an error in the log. I have my email plugin configured and my from plugin configured with the captcha keys. I have tried on a couple different sites and I can’t get it to work locally or in production. I don’t know how I can troubleshoot this. Any ideas?

I just tried again on a blank Antimatter site and the darn thing works. So I will do some checking to see what is different.

I figured this out so I thought I should mention what I found. The skin I am developing had a “forms” folder that had some old forms from way back in early Grav days. I just deleted the forms folder in my skin to fix my issue. I am sure this will fix other form issues I had seen too.

Good you figured out Mike, I missed this thread! It surely missed the nonce field in the custom form twig, which was added to forms a while ago.