Newbie, installed with project space skeleton but can't log-in to admin

admin

#1

Hello,
this is my first install of grav. I’m not an experienced web site … person.
I’ve installed grav using the Project Space skeleton. When I loaded the site for the first time everything looked fine but when I went looking for the admin panel I’ve found that I’m unable to log-in - I don’t have a username and password, I’ve not been asked to create one.
I’ve tried re-installing the admin plugin (manually) but that hasn’t helped.
Is there a page I should visit to create my admin account?
In the user documentation it says:

With the latest version of the Admin, you will be prompted to create an admin user account when you point your browser to your site.

but this hasn’t happened for me.
Thanks so much for any help or advice you can give.

bye
Adam


#2

I’ve since read the README.md file in the plugins/admin folder where it says:

Alternatively, you can create a user account manually, in a file called user/accounts/admin.yaml. This filename is actually the username that you will use to login. The contents will contain the other information for the user.

see the README.md file for a full explanation

it appears to be resolved / solved

thanks, bye
Adam


#3

If you delete all the .yaml file in /user/accounts/ and go to http(s)://yoursite.com/admin you will be ask for a new user and password. Perhaps you should update first your grav and plugins
with bin/gpm selfupgrade


#4

Thanks tim, I’ll give that a try.

bye