Problem with user/accounts

Dear Grav community,

First of all, I am fairly new to Grav and totally new to this community so if I break any formal or informal rule in my post I regret on forehand. I have made extensive searchers to find a solution to my situation but without success.

I’m administrating a homepage that operates through Grav. I have mainly used the admin-plugin but after a computer malfunction, I have lost my password to the admin account. I do not receive an e-mail when using the “Forgot”-button. I’m now trying to solve this problem through the server (the page runs on a Droplet at DigitalOcean).

The first time I logged in through the Droplet, there was only a Zip-file. When unpacking it, I found the folders associated with Grav. However, the users in the folder user/accounts does not contain the users associated with the page that I have created through the admin-plugin. I have tried to change the password manually through edit the yaml.files of the existing users but cannot login. I also tried to add a new user through `php -f bin/plugin login newuser” but could not log in with the new user either.

Have I overlooked any possible solutions?

@johnjohnjohn, You could try to delete the user file in /user/accounts/user_xyz.yaml. You will then be forced to create a new account when accessing the site.

Thank you for fast response! I forgot to mention that I have tried this step but the strange thing is that I have not been forced to create a new account when accessing the site. Further, there are (non super-)users which are not visible on the server that I can still login with (even though I have emptied the folder on the server). I should add that I have restarted the server after removing all users

@johnjohnjohn, I’m afraid I haven’t much more to offer… Any progress since last reply?

Still no progress. I cleared the cache and removed all users, and restarted the server but the login (i.e. .com/admin) looks as usual. What puzzles me is that when I ask for reset instructions I receive the following message:

Cannot reset password for my.email@host.com, password reset functionality temporarily blocked, please try later (maximum 60 minutes)

Hence, there is still information concerning my user and e-mail on the server even though I have removed all users.

Do any one else have any ideas?

@johnjohnjohn, Hm, I do recall a caching issue with Admin which surfaced last month and should have been fixed.

  • Did you perhaps upgrade recently before the issue occurred?
  • Have you upgraded to the latest release (released a few days ago)
  • If issue persists, I would suggest to log an issue at Issues · getgrav/grav-plugin-admin · GitHub

Thank you for the advices and questions,

  • I did not make any updates during this period. I have recreated backups so everything is the same in terms of version

  • I just tried to update by using bin/gpm selfupgrade, strangely, it updates successfully but when I try to update the plugins (bin/gpm update) it says I still run on 1.6.

I even removed the login and admin plugins but when I visit domain.com/admin there is a login panel, and when I ask for reset instructions I still displays my e-mailadress (see my previous post).

@johnjohnjohn, Are you sure you are making changes to and accessing the same site???

I even removed the login and admin plugins but when I visit domain.com/admin there is a login panel

This hints towards a caching problem…

  • Try $ bin/grav cache to clear the cache of Grav and check if folder /cache has indeed been cleared.
  • Clear cache of Digital Ocean
  • Clear cache of browser