Metadata won't come up as desired

I have a problem with setting metadata in …partials/metadata.html.twig.
I set http_equiv according to code but it comes as ‘name’ in result whatever I do.
There is also a line: that comes up from nowhere!
Please, help me!
It is certainly not a big issue but I cannot see the point yet.
I precised that I have looked at the forum on this subject before posting… there is something similar but not sufficiently clear to succeed.
Also in the documentation, the metadata exemple do not shows the http-equiv tag form.
Thanks in advance.

Currently there is no support for http_equiv metadata. That will have to be added. Please submit an issue here:

Actually scratch that, there is support! I’ll test to ensure it’s all working properly.

ok so supported? or not ?
where is GravCMS 1.0.0-rc.2 comes from?

yes, it is supported. I’ve updated the docs to reflect this.

I think the GravCMS is coming from a corrupted ‘generator’ tag. You override the generator tag with simply generator: "Your Custom Generator" in the metadata. Also added this to the docs.

ok thanks I feel better
what about http-equiv? why is it taken as name while it is not?
I would like to generate these 2 lines:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="Content-Style-Type" content="text/css" />
how should I write?
Could you precise what is to be in system/site.yaml, user/site.yaml and user/pages/index.mdrespectively?
Is it just overwrite when present?
When you write ‘corrupted’ generator, how is it possible? Isn’t it that it is made to be able to measure the audience of Grav (which I understand and respect: it’s just that I 'd like to understand how http-equiv is not getting to its point ?
In avance, thanks.

In site.yaml

    content-type: 'text/html; charset=UTF-8'

Although if your going to be setting this site-wide, your better off just hardcoding this in your base twig file. Why do that extra work?

Antimatter theme for example simply has this in the partials/base.html.twig:

<meta charset="utf-8" />

content-style-type is not supported, and I have no clue why you would ever need it, especially as your setting it to text/css which is the default and pretty much only option anyway.

thank you very much: i feel better.
I am a beginner in coding and so I am trying step by step…
Under, the reference from which I went that way:
recommendation of the W3C
Please, have a look and tell me what you think…


to rhukster…

My recommendation is not to use content-style-type it’s just a waste of bytes. There is zero benefit of it.

thank you very much