Localhost config not working in 0.9.4?

In /user/config/system.yaml I have:

  enabled: false

In /user/localhost/config/system.yaml I have:

  enabled: true

But the debugger is not enabled. If I reverse the settings I get the debugger and it reports that the environment is localhost. Do I have the localhost config in the wrong place?

Looks fine to me. If you clear cache does it work? (bin/grav clear-cache) does it work?

That fixed it. Caches are a bitch.

I think you have some underlying issue that is causing cache not to automatically clear.

Can you check cache: check: method: is set to file in the system.yaml?

Do you also have trouble with Grav not picking up changes to your content?

It’s set to file.

I’m also running through CodeKit’s server. Maybe there are cacheing caches?

That could well be it!

Grav should really be able to detect changes in configuration files as it takes md5 from the last modified times from all the files. There is a way to prevent this check from happening, but it’s not documented, so I don’t think you’ve changed that setting…

There might be some other bug in the action causing it to ignore localhost config in some cases…?

Bob has definitely had other scenarios where config/data wasn’t recached. It could well be the CodeKit server. Perhaps you could try it without that server Bob and just use the .scss.sh script to automatically detected and build any scss changes. CodeKit is probably overkill.