Grav Admin Log In CSS not Loading using localhost

Hey @all,

(this is my first post here, so pls be kind if i missed something or if my english isnt perfect since i’m not a native speaker/writer :wink:

I’m now using grav for some weeks, since I reworked a website using grav and stuck to it.

For development I’m running the website in a local environment using xampp.
For small changes on the live website I use atom with an ftp plugin.

To get to my Problem:
two days ago I took a complete-backup from the live website to continue working/testing on it in the local environment. I changed some htacess entries (rewrite) as usual.

Since then the Admin-LogIn Page and Admin-Page(after LogIn) are apparently loaded without css (see attached Screenshot)

The Live Website Admin Page is still fine. So is the localhost Admin Page of an old Verson of that Website.

I checked:

  • admin plugin css files --> still there
  • sourcecode of the admin page --> everything normal/fine
  • overwrote the admin plugin with an old plugin version --> still not loaded
  • an old backup version of that website at localhost with old grav an admin plugin version --> working fine

I dont get it why this is happening. Did the new Grav Version change something that effects the localhost copy?

Looking forward to your answers!


have you already tried to find out what is going on behind the scene by looking into your browsers dev tools ?
usually, invoked by hitting F12, then look for error messages in console for something like css not found…
this should give you a clue what is going wrong.
and, btw., you could also try docker as a local development environment, much faster and reliable than xampp :smiley:

thank your for answer, there is actually an error while loading the css:


Seems like the page tries to load the css through ssl/https and obviously its failing course its not enabled on localhost. That’s apparently also the reason why its working on the live website.

I checked the system.yaml and htacess but found no forced ssl. Do you have any idea?

setting the custom_base_url manualy didnt work.

no, sorry, I have no idea, never came across such a behaviour :frowning_face:

@Ph1l3mon Never seen something like this before.

You said:

I took a complete-backup from the live website

Did you try emptying the cache folder.