Lightslider stopped working for me

I had a working lightslider on my page, but after the last upgrade it stopped working, showing only one image, nothing else.

Is there anything I have to change?

Lightslider did get quite a bit update a few weeks ago. I suggest reading the updated README file and compare the configuration to yours.

The reason for these changes is that the Lightslider script itself had a major update, and I had to update the Grav plugin to match it.

Seems the last update was a couple of months ago, how time flies :slight_smile:

I’d put aside the lightslider problem for quite a while and didn’t try to fix it until a few days ago. But I’m still stuck even after completely reinstalling grav. I simply cannot get the thing to do what it should. Feeling stupid really.

Ok I’m afraid I’m back with my lightslider problem. I tried the Skeleton Demo and it works (of course) as expected. I compared the plugin files to the ones I use in my site and they’re identical. But even when I use the from the demo I still see only the first slide and its text or (in image mode) ALL images one after each other.

I convinced now that I’m doing everything right here, but still the plugin won’t work. Have you guys any idea what’s wrong here?

Is it possible that another plugin is doing that?
I installed/reinstalled all the plugins by commandline and manually, back and forth and even tried a fresh grav installation, then the plugins.

1 Like

Oh boy, I just found the problem. The ‘Lightslider’ plugin is misfunctioning as soon as the ‘external_links’ plugin is also installed.

I suggest to create a new demo, consisting of the ‘single page’ features as well as the ‘shop demo’, ‘blog’ and so on. Including all available plugins. That way we could make sure that one plugin is not interfering with another.

You should be able to disable the external links plugin on that page that sets up the lightlsider panels?

Oookeyy. How do I do that?

It’s in the documentation of the plugin:

Ok thanks. Works here. But disabling a plugin for this reasons also means you first have to know it disables another plugin. I guess there must be a better way to fix this. Could you contact the plugin author and ask him to look into this?

The best thing to do would be for you to open an issue on the Extended Link plugin project:

And provide him with the information that he would need to reproduce and fix the issue. This is probably not a Lightslider issue per say, it’s a user issue with a specific combination of scenarios. If it turns out to be a Lightslider issue, Sommerregen will open an issue with Lightslider and we’ll get it resolved. This is how open source works, everyone cooperating together :slight_smile:

Done :slight_smile:

OK, updated. It shall now works with the LightSlider plugin.

Have fun :D!

Great! Out of curiosity: what was the problem?

You can see from the commits:

To summarize my commit: The External Links plugin parses the whole content into a DOM document structure (to deeply investigate links and their contents) and back afterwards.

The issue comes from transforming back the DOM to plain text. I used $dom->saveHTML($node) to do the job, but unfortunately self-closing tags like <hr /> were returned as <hr>. To overcome this issue I save the DOM structure now with $dom->saveXML($node) which gives at least <hr/>. This is correct, but unfortunately it is not recognized by the LightSlider plugin. Therefore the regex afterwards to add a whitespace before the slash in self-closing tags, to finally get the required <hr />.

:wink: Nice. Thanks again for fixing this so quickly.

Dear @nickbe, thanks and sorry for any inconvenience. The External Links plugin was more or less (unfortunately) a beta release. With version 1.1.3 this should be no longer the case.

Hey, no problem. Bugs are part of the game :wink:
Just tested 1.1.3, but it still deactivates lightslider. Sorry.

The following plugins are also installed here:


Strange before I released it, I checked your issue and it was solved. I checked it again and LightSlider is working for me. Just tested the Shop skeleton and installed External Links v1.1.3…