Lightslider: cannot reach make it working


#1

Hello, I’m trying to create a slider, first tryed with owl-carousel, now with lighslider plugin, but it don’t works. I tried also the sample on the readme, but nothing works fine.
I tried 3 differents md files, one with the standard
# Shop Geek Stuff
## We have all your **geek** needs covered..
___
# SnipCart Powered
## **Grav** plus **SnipCart** equals easy shopping

then two using directly html with the


separator,
but in any case the slider don’t works.
Here you can see what’s happens:

I’m using the Quark standard theme, I hope this isn’t the problem!


#2

Your images have to be in your lightslider.md folder!
Looking in your sourcecode tells me you put them in the /grav/images folder.


#3

@arank I think you’re looking at the thumbnails automatically created by the javascript. I have two jpeg images image-1.jpg and image-2.jpg in “test” folder


#4

Ah, sorry, my fault.
Can you post the content of your lightslider.md file?
Did you name it lightslider.md?
Your page is modular?
If not, here is how to get it working on non-modular


#5

@arank this is a screen of my space on Top page:


As you can see if set the md file to lightslider and the values inside are the standard values ( I’ve only used 2 images and text parts instead of 3)
this is the screen of the parent page:

Thank you for your help, I’m really trying to understand which is my error :frowning:


#6

Try out:

  1. In your test folder: Just use _top as folder name, don’t use 01.
  2. In your modular md:
content:
    items: '@self.modular'
    order:
        by: default
        dir: asc
        custom:
            - _top
          
---

Leave out date and body classes.

  1. In your markdown:
# Shop Geek Stuff
## We have all your **geek** needs covered..

---
# SnipCart Powered
## **Grav** plus **SnipCart** equals easy shopping

---

#7

no changes :frowning:
what I can see is that in the page shown is the entire text of the lightslider.md page, also the --- lines, like if the raw content of the page isn’t processed


#8

Is the plugin enabled?
Did you check another theme? Might be theme related…


#9

plugin is enabled, elsewhere I cannot see the first image, I tried also with antimatter, maybe I have to set to process markdown first? ( at the moment I’ve setted “process twig first” at yes in system.yaml


#10

@arank EUREKA! I found the problem:
making a compare between the yaml files in config folder of my grav and which of the shop site skeleton I found that in the shop skeleton the processing of twig is disabled!
It’s a normal configuration? Because setting the processing of twig false, some other plugins seems not to works fine.
If I set in the frontmatter of the lightslider page
process:
twig: false

All works fine!