Installation to XAMPP on Win10


I’m sorry if this questions was allready answered somewhere, but I could not find s similar problem. I’ installed XAMPP on Win10 for testing purposes. I’ve also downloaded the lastest Grav+Admin zip. This I’ve unpacked to the XAMPP folder: c:\xampp\htdocs\grav. When opening the browser and entering localhost/grav I get the following message: Please run: bin/grav install.

But how and where do I have to run it?? I understand that this is a linux command!?. I’ve tried to run it via the Linux sub system, but the command is not known.

Hope someone can help me!


XAMPP: V3.2.2 up and running
php: V7.1.11 up and running

Try navigating to c:\xampp\htdocs\grav\admin in your browser.

If that doesn’t work then go to that directory and run bin/grav install and it should work.


if I enter the path into the browser I get the message that no such file/directory exists. There is however a directory “grav-admin” But this also doesn’t work. I’ve also tried to enter localhost/grave/admin but get also just the output to run bin/grav install.

Where do I have to write the command? On cmd/powershell I get the message that the command is not known…


Oh I think I see what is going on. Navigate to c:\xampp\htdocs\grav\grav-admin and that should prompt you to create a user account. If not, try running that command from that directory in powershell.

Sorry, didn’t read that you had already tried navigating there. You might want to try downloading grav again? Whenever I navigate to the directory it is installed in my browser, it sets itself up.

And it seems those commands don’t work in the windows terminal for whatever reason.

It’s probably because you downloaded a skeleton.

Skeletons requires you to run bin/grav install once it’s unzipped.

An alternative would be for you to download regular Grav and Admin Plugin, which does not require to run this command, and then install the theme you wanted from the Themes tab.


@bbricker87 When entering the path till \grav-admin I just get soemthing like a file explorer where I can navigate through the filestructure (The only folder I see is “vendor”). I’ve now retried to run the command via Powershell. When I enter the command in the root grav directory it now opens the file but just showing the php code in it.

@paul no I just downloaded the normal grav+admin plugin zip. To be sure I’ve just downloaded the package again. deleted the files on XAMPP and redecompressed the grav cms to the directory again.

“Where do I have to write the command? On cmd/powershell I get the message that the command is not known…”

Exactly the same problem for me.
I think that developers often forget that we do not have a dev environment on our computers, and that for a command to work under Windows, it has :
1- to be a .exe
2- and to be added to the PATH environment variable.

Point n°2 is not necessary if we execute the command from its folder, but a .exe is absolutly necessary under Windows !

So, I’m stuck too, with the package manager (GPM) and all.