Cannot run GPM on win cmd

Hi there. I’m dummy with grav, so maybe my issue is simple… but can’t find a solution on the web.
I’ve installed Grav on my Windows 10 pc and i’m trying to add some plugins with GPM.
I go to cmd and type php -v
and it’s ok, php application is added to windows system.
So I type C:\WINDOWS\system32>php bin/gpm index
or C:\WINDOWS\system32>php grav/gpm index
or backslash too, but i always get “Could not open input file: bin\gpm”
I checked OpenSSL support: enabled and cURL support: enabled
What is lacking? Thank you!

Slash-direction is not a problem anymore on WIndows, but is this the right folder? You probably need to run the commands in the right folder, so cd C:/My/Grav/installation before you run these commands.

1 Like

Same result… as php.exe is into C:\xampp\php\ folder, i type
C:\xampp\php>php grav/gpm index
and get
Could not open input file: grav/gpm

@hellen_sfms Mistakenly you changed your working directory to the php installation.

As OleVik said, you have to change your working directory to the root of your Grav installation.

That’s the folder in which you unzipped grav-admin-v1.6.23.zip or grav-v1.6.23.zip. Considering you are using Xampp, it will probably be something like C:/xampp/htdocs/grav-admin

> cd C:/xampp/htdocs/grav-admin
> php bin/gpm index
1 Like

It works. Thanks a lot for your help, issue solved!!