How to tun grav install on Windows?

Hello, I am very new to Grav and I want to execute “bin/grav install”. How can I do that on Windows?

I cloned grav into “C:\xampp\htdocs\grav” and opened the MINGW32 “Git Bash” terminal. From there I executed “cd /c/xampp/htdocs/grav” and “bin/grav install” but then I only get the response “/usr/bin/env: php: No such file or directory”. :’(

Ok! Got it! I had to add “C:\xampp\php” to my system environment variables. Sorry for bothering you guys! :slight_smile:

Glad you got it sorted!

I have the same problem! where did you add the root path?

@Mathias: Maybe this video helps you?

Thanks for the quick reply didnt help my case though, I think its just not clear to me how to use git-bash with grav, it seem that I am running in circles… I have grav installed and now I would like to try the admin panel in the doc it states it can be installed like so: ‘$ bin/gpm install admin’.

@Mathias: I had this issue just a moment ago myself. I’m running Grav on USBWebserver (stand-alone server package similar to Xampp) on Windows 7.

  1. First install Git for Windows ( Just use the default settings when installing.

  2. Add the php root path to the Windows System Environment variables: click Start > type “env” in “Search programs and files” > select “Edit the system environment variables” > select “Environment Variables” > Edit the system variable “Path” and add the full path to where you have installed php (for example

C:\{some folder name}\php).
  1. Go the root folder of Grav using Windows Explorer. Here (right-click) and choose “Git Bash”. You now enter the Terminal program where you can use the Grav CLI (you’ll see the $-prompt). Here you can enter for example:

bin/gpm selfupgrade -f

to upgrade Grav to the latest version. Follow the blog post to further install the Admin plugin.

This worked for me. I now have the Admin beta running on my local installation of Grav running on Windows using USBWebserver :slight_smile: :slight_smile:

If you need further help, let us know.

1 Like