Grav problems installing on webhost

Hi all,

just wanted to try Grav cms which have excactly the features i want.

I downloaded the blog-skeleton, did som changes in some text files ie. the date format and uploaded the whole thing to my own domain, which is hosted by

Now I got the infamous Grav problems:

  • /bin/composer.phar is not executable
  • /bin/gpm is not executable
  • /bin/grav is not executable
  • /bin/plugin is not executable

I tried to change the permissions described in the Grav help system and upload them again, didnt help!
I also tried to run the shellscript locally in my folders root, didnt help!

Permissions on the /bin folder is 755
Perrmissions on the 4 executables is 775

Any solutions to get this going ?

PS. I uploaded Grav without setting it up locally first because I want to make the ajustments online.

I had a similar question here:!/general:problems

Could you try those approaches and get back to me if it’s still not resolved?

i got this now:

drwsrwsr-x@  6 niels  staff      204 12 Dec 13:48 .
drwsrwsr-x  24 niels  staff      816 15 Dec 23:12 ..
-rwxrwxr-x@  1 niels  staff  1181186 12 Dec 13:48 composer.phar
-rwxrwxr-x@  1 niels  staff     1640 12 Dec 13:48 gpm
-rwxrwxr-x@  1 niels  staff     1434 12 Dec 13:48 grav
-rwxrwxr-x@  1 niels  staff     3656 12 Dec 13:48 plugin

Uploaded it, and it still doesnt work :-/

Shall i delete the user/plugins/problems folder?

It’s strange though.
I’ve previously got Grav installed by only installing the core packages without a skeleton. I didnt manage to get the look of the site just like I wanted it, therefore im now trying the blog-skeleton package.
Could it be that there some issuses with the blog-skeleton files?

I’m on a Mac using Transmit to upload the files.

It’s not the local setup that’s the problem, it how the files are permissioned after you upload with transmit.

Your ls -la example is on your local mac, not your remote server where you have the problems.

Try checking the remote files with transmit and making sure they have executable permissions.

Thi is what it looks like in Transmit:
Uden navn

Ok, that’s odd. Is this a Linux host?

BTW, quick fix is just to remove the problems plugin. Don’t let this troubleshooting get in the way of your site being up :slight_smile:

I just want to get this fixed if its a problem.

Yes, it is apacheservers running on Linux (dont know which one) :slight_smile:

Okay i’ll remove the plugin. It is still strange though.

Okay, im trough !

Thanks for help!