Can't get Grav working

I’m having some major issues getting Grav working, and I’m really not sure what the issue is.

Installed the “Core + Admin” version - for some reason, whenever I try to navigate to the main index page (site/blog/) - it just redirects to /blog/admin and shows a blank screen. The first time I tried this, I got the “problems” page, but after that I could never get that page to show up again, even after removing everything and starting over. No errors reported in PHP error logs.

Installed one of the skeletons - navigating to site/blog/ gives me a 500 server error. The error logs say: " Uncaught exception ‘RuntimeException’ with message ‘Please run: bin/grav install’" - tried running ./bin/grav install but that just gives me an error “require_once(/var/www/site/public/blog/bin/…/vendor/autoload.php): failed to open stream: No such file or directory in /var/www/site/public/blog/bin/grav on line 21”.

Running on Apache 2.4, PHP 5.5.31, Ubuntu 12.04. I did chmod 755 and chown www-data:www-data to everything, but tried all kinds of different sets of permissions/owners with no change.

ok, your core+admin install is trying to redirect you to the admin so it can create a default user. It’s failing here. What were the errors reported on the ‘problems page’? Probably something there was critical. To get the page back, simply clear the grav cache (bin/grav clear)

On the skeleton install, that sounds like you didn’t have a full skeleton release with all the bits. Perhaps you downloaded the ‘zip’ from the repo, but that is only the user/ folder. For example try this:

This one is the release of the skeleton so that zip is actually generated by a script that includes Grav+content+plugins+theme+vendor-folders etc.

Other than that I suggest checking out the Troubleshooting section of the Grav docs:

Also not sure if you are able, or want to try this, but we have several guides and tutorial s about setting up a fresh VPS for Grav in the optimal way. You can see these under the Hosting VPS section in the docs.

Thanks for the response.

So I copied over the files from the skeleton link above and that installation actually worked. However, when I copied over the admin plugin (and its required plugins), I had the same issue - navigating to the /blog/ url causes it to redirect to an admin folder that doesn’t exist. Tried cleaning the cache but it reported “Nothing to clean”. No errors in the PHP error log either. Any other way to access the “problems” page?

How are you installing the admin plugin? Are you installing via GPM?

As an update, I was able to fix this issue by changing my .htaccess file to “AllowOverride All”.

With that said, I have another problem that I’m struggling with - now, the admin page loads but gives me an error message “Cannot connect to the GPM”. I found a post on the github ( where another user had the same issue, but so far changing permissions and ownership hasn’t worked for me.

Any ideas? (sorry for being such a bother)

Just saw another use state that his CA certificates were not installed which would cause problems with SSL which is required for GPM. I would check to see if you have openssl PHP module installed first though.