Grav not shown in localhost/~user

I have intstalled Grav using Github as in the installation guide. However, Its not shown in my localhost directory. I have other files in the just to test my localhost and its there. How to solve this???
I have php5.5. Screen Shot 2015-06-24 at 2

If you can reach:


Then you should be able to reach:


Ok, I somehow got it to work. But, it asked me to run bin/grav and after running it
it shows “Access denied must be Root…” on my terminal and on my localhost it says “Theme ‘antimatter’ does not exist, unable to display page”. What have I done wrong?

Please help, thanks a lot!

Sounds like you have tried to install from the GitHub zip file. Easier to just Grab the pre-built package from the Downloads page here on Those zips have everything you need, just extract and point your browser at the directory.

FYI The GitHub zip file (or cloning from GitHub) does not include the vendor libraries (3rd party), nor a theme, or any plugins. The bin/grav install is a CLI command that installs the antimatter theme, a couple of plugins, and then runs composer update to pull down all the composer libraries.

Omg thank you very much! It works now. By the way, how to install the GPM via terminal or manually? Thanks!

GPM is part of grav, just type bin/gpm and you will see the commands.

NOTE: these require PHP 5.4+ running in the terminal. So you can check that with php -v. If your on a shared hosting server, check out the hosting section on to see some examples of how to get a newer PHP version running even when the default is 5.3.

Alright thanks. Is it normal that I can only reach my Grav page from localhost/-user/-grav and not localhost:8000 as said in forum? Sorry but I’m new to all this.

Yes, that’s normal. port 8000 is only if your running the PHP built-in webserver.

Alright thanks for your help!

One more, when I run bin/gpm selfupgrade, it says “Fatal error must be root”, how to resolve this?

Not really sure, never seen that before. I would need to get much more information about your server setup. Obviously there are some permissions or security restrictions in place. You might want to contact them and ask them about it.

This is the error > “FATAL: Must be run from ROOT directory of Grav!logout”