Grav 500 Internal Server Error


I have a website that is hosted by namecheap – uses cpanel. I unzipped 3 grav skeletons into 3 distinct folders in my webroot, home1, resume, and blog. I extracted the big picture skeleton, resume skeleton, and striped blog skeleton respectively. Only the big picture skeleton works ( while the other two ( and give 500 internal server errors. I cannot figure out why.

Have you tried these?

I am not really sure how to do most of that…still picking up basics. I don’t really handle anything with php, I just use filezilla to send files to webroot and have namecheap handle them. What confuses me is that one of the skeletons works, so shouldn’t all my permissions and settings be fine for all three?

Also, to give some idea of the end goal…I want to have a landing page at along the lines of the big picture theme and then two external links on the top to which will use the striped theme, and an external resume ( which will use the resume theme

I would think they would be the same. In FileZilla you can quickly check the permissions by right clicking the file/folder and choosing File Permission

Yeah, i know what you mean with the landing page. I don’t know that much about .htacess files so I can’t necessarily give you advice there.

They all have the same file permissions when I checked that; still not working…I just don’t know what I need to change in the code in the Grav files as I am pretty sure all of the skeletons are meant to just work out of the box and one does so I assume my settings and system are all up to par.

The documentation page that @vivalldi linked is a collection of common solutions to 500 errors.

If one Skeleton works but the others do not, try first disabling the page cache (edit user/config/system.yaml) and also check how that file differs from the skeleton that works, and the one that does not, if there’s any difference.

I was having this issue, and reviewing the error log on my server it turned out that it was a permissions problem. to get grav up and running all that was needed was to remove Group write permissions to Index.php and to the Folder Grav was stored in.

1 Like