Internal Server Error 500, after update

Hello there, I’m new to the GRAV world. I’ve installed the version from Gantry (the one that has Grav, Grav Admin, Gantry 5 and Helium skeleton) to test how it worked.

After 2 weeks of testing everithing was just fine, including the updates via the GRAV Admin.
One week later accessed the Admin and tried to update it again, but I had an error (the screen error was fast, but I was able to read something that said a permission error in the /system folder), and then the site and the admin backend has become inaccesible.

I got a 500 internal server error, no matter what I do. Followed all the steps mentioned here: https://learn.getgrav.org/16/troubleshooting/internal-server-error without success.

I will appreciate all the help I can get.
Thanks!

It seems during install, grav changed the permission to something your host provider doesn’t like. I noticed that when I updated my site, the index.php permission was changed to full access. Changing it back to 644 fixed the 500 error.

Look in your errors log to find out what the permission issue is. My system folder permission is 775