Footnote linking problem

I’m trying to insert a footnote in the markdown syntax.

  1. I turned on Markdown Extra in the configuration
  2. on the page I added: [^1]
  3. In the footer of the article I added: [^1] Footnote description…

However, the problem is with linking. The URL to which the footnote links in the article looks like this:

when the actual article URL is:

In other words, it links to the home page, not the actual article page.

@q3d, Unfortunately, I cannot reproduce the issue.

On a fresh Grav install:

  • I’ve enabled Markdown Extra in /user/config/system.yaml
  • I’ve added [^1] somewhere at the top of page Typography
  • Added at de bottom of Typography: [^1]: Description of...

Clicking the superscript ¹ at the top, brings me to the bottom of the page. Clicking the ↵ at the bottom brings me back to the head of the page.

NB. Probably a typo in your post: The footnote itself should have a colon: [^1]: Description of...

Ok. I will check this on the default theme.

With the default theme, of course it works.
What might influence this behavior in my case?