Fetch Failed

I’m having issues when using the admin tool. When trying to upload a 744kb jpg, I get the error “Fetch Failed:” after saving. However, when accessing the page on firefox, the photo is handled correctly. Here’s a screenshot of the error message:
I updated grav to the newest version, but it didn’t solve the problem. Any ideas? Thanks in advance.

So it fails in what browser? And it works in Firefox?

Thanks rhukster, I found a solution to the problem. It seems the admin panel can’t handle files containing more pixels than 4300x4300 - regardless the file size. Reducing the picture solved the problem. Here’s the post that helped me:

btw. had the error message on opera, chrome, firefox and safari.

It’s not a general Grav issue. I just tried with 6000x6000 images, and they are uploaded and handled just fine.

Could it be an issue with your PHP memory limit or the upload file size? (although the latter would print another error message)

Every now and then I’m getting fetch failed error message too.(Firefox Browser)
I think it’s not related to images, because this error occurs sometimes after logging in, or after clickin save button, though changes made are saved.
Sometimes this message pops up simply after clicking through the menu items in admin.

I might have noticed the same problem on Firefox, when clicking away while a network request is happening (to get notifications / updates for example).

Does not happen in Chrome or Safari, need to check if it’s a general Firefox issue.

Had this happen today using Chrome. USplash image so around 4300px.
I’ve had Grav installed for two days and I’m finding it very time consuming and frustrating getting the simplest things done.
Very steep learning curve.

Looks like an issue we can’t easily replicate by just uploading the same image on a different site, so it might be a server config issue, and I’m sorry for the pain.

You can also simply upload the big image using FTP into the page folder.

created a new firefox profile without any extensions/plugins (especially https everywhere, noticed before some pages not loading correctly).
since then no more fetch failed message