Grav bug has broken our site

Hi there,

just wondering when will this bug be fixed?

We spent two months developing a new grav version of our website only to get affected two days after launch by this extremely annoying and nasty bug.

Website is unreadable now, this is hitting us bad as we are losing business as we speak.

Any idea when can this be sorted out?

Hi, we tracked down the issue yesterday and the fixes proposed in that issue you linked seem to work fine.

We’ll probably do a bugfix release today, and in the meantime you have two options: rollback to Grav 1.2.4, or install the develop version (or just download this file and put it in the corresponding folder).

1 Like

Hi there,

thank you for the prompt reply, in the meanwhile we patched it up by rolling back to previous grav version, I will forward this to our developer so he can better assess the next step/s.

This should be sorted in latest Grav release.

here we go again, so another site another issue, basically admin is stuck and can’t open anything, can you please take a look and let me know, again Im not a dev so cant tell whether is the same bug or something else causing this.

Let me know if you need access creds

Dev was able to share this

jQuery script is not loaded correctly

PM me some login credentials.

I’m not sure how JQuery cannot be loaded in the admin, is it possible that something you are running is blocking it?

BTW Jquery is there and can be accessed directly. Have you changed the Jquery version or prehaps changed the Jquery asset collection? That is shared between site and admin, so that could be an issue if you messed with it.

thank you @rhuk issue seems solved, not sure what went wrong, now back to loading speed implement

now seems that site is been broken again by this {{[clients.image].cache.url() }}

Dev is saying that Grav upgrade doesnt support this method anymore and now site is broken, just wondering is this a bug?

Does this happen often?

Nothing has changed regarding page media handling that I can think of.

@rhuk so I tried to simply write headline in capital letter, next thing I now icon image is gone, I cant figure out why because I can still see it in admin. Developer is gone on vacation, can you please help me get the icon back?

Here is the page

It seems like this image is missing:

@csixtyfour the image is there on the server I havent figured out why is not loading, not sure the admin shows .png and then the images on server are .svg something is off not sure what went wrong.

Any suggestion is truly appreciated.

Why don’t you re-upload it if you still have it ?

@AmauryH as I tried to explain I did that already but didnt work, for some reason I ignore image doest load, also Ive been asking developer whats the point of having a admin interface if I need to upload image via FTP then, he mentioned that he did this because grav doesnt support svg and images needed to be retina ready, but Im not sure.