Error 403 under Uniform Server (solved!)

Hello, everybody!

I just solved an issue that was giving me headaches and I think maybe others would benefit from my experience, so here I am posting this info:

Under “Uniform Server” (a very nice WAMP stack, IMHO…) I wasn’t able to host a Grav instance: all I was getting was a 403 error: “Forbidden: You don’t have permission to access / on this server.”

After some debugging I came to the conclusion that the issue was in the distributed .htaccess: there is no “Options +FollowSymlinks” directive in it, but apparently that is needed, at least with my configuration where I have Uniform Server handling several virtual hosts.

Not willing to alter Grav’s original .htacces I added that directive in Uniform Server httpd-vhosts.conf, in my grav vhost section, which now reads:

<VirtualHost *:${AP_PORT}>
ServerAdmin root@localhost
DocumentRoot ${US_ROOTF}/vhosts/grav
ErrorLog logs/grav-error.log
CustomLog logs/grav-access.log common
<Directory “${US_ROOTF}\vhosts\grav”>
Options Indexes Includes
Options +FollowSymlinks
AllowOverride All
Require all granted

Hope this can help…



That should only be required if you did have Grav installed with symlinks to themes, plugins, etc… There are no symlinks in the default Grav package…

Hello Andy!

No, I have no symlinks (nor shortcuts, nor_ junctions_) in my Grav installation. Mine is a “vanilla” installation (from the wizard) under Uniform Server (11.8.2). Only thing, if this may matter, is that US is installed on the root of a secondary (“D:”) partition, but I really don’t think this may matter as Uniform Server is a totally portable application.

In the meanwhile I also discovered that the same issue is present with October CMS, while none of my Joomla virtual hosts have this problem, but this is easily explained as Joomla’s default .htacces has the “Options +FollowSymlinks” directive in it…

… and TBH, I think this is an Uniform Server issue (not a Grav and/or OctoberCMS issue), but anyway, just to spare some headaches…

Ok, cool, thanks. I do need to start a windows-specific issues/fixes document and add this to it. There seems to be a lot of WAMP variations for windows and each one has it’s own quirks and issues that have to be tweaked.