Internal Server Error

I am trying Grav for a new website. I am quite a noob, so please forgive my lack of knowledge.

Working on Ubuntu 14.04, I have a server set up with Apache, with a website associated to a certain domain, The website is under the public_html folder, and it works perfectly. Now I have downloaded grav into that website’s folder. From what I can understand after reading the Learn pages, Grav should already be up and running if I point my browser to Is this correct?

If it is, it’s not working: it shows an Internal Server Error. After reading this ( I have tried adding the info.php file to the grav folder, and it still shows the Internal Server Error. The error.log file says “myuser/public_html/grav/.htaccess: Options not allowed here” several times. What’s wrong?

Basically you need to add AllowOverride All in your .htaccess. The location of that depends on your setup. If you are using virtual hosts, it will go in the virtual host config and probably replace AllowOverride None, but if you don’t have that setup, it could be the default webroot setting in your apache2.conf.

I found this to make it a bit clearer:

Thanks, it worked! I also had to give wirting permissions to a lot of files and folders, but now it’s running :slight_smile: Now to the fun part :smiley: