Htaccess Options - apache userdir mod


I would like to know if an apache virtual host is required to run grav.

I tried with and without. Both are working.

But when I don’t use virtual host, with the userdir mod at localhot/~user, grav don’t run because of one line in the htaccess file :

# Begin - Prevent Browsing and Set Default Resources
Options -Indexes

I found an error message in the log of apache :

“options not allowed here”

I can fix it easily by puting this line in comment, but I don’t know why this option is here if it produce an error.
So virtual server is a better way to the install ?



Maybe it should be mentioned in documentation’s page :

16/basics/requirements : Apache Requirements

When running grav without virtualhost defined with Apache, an error happen (“options not allow here” in apache error logs) and you have a “Internal Server Error” in your browser for the home page.
You can fix it, editing .hthacces file of grav’s folder by commenting the line :
Options -Indexes
like this
# Options -Indexes