"The requested URL /admin was not found on this server"

Hey guys,

I’m getting “The requested URL /admin was not found on this server.” after the admin plugin is installed. The default grav site is working fine before I execute bin/gpm install admin. After I execute the plugin install, when I visit the site’s root, it automatically redirects to /admin and I get the error message above. When I install from the *-admin.zip file, I get the same error right from the start.

Is this a permissions issue or something else?

Try the following advice: http://learn.getgrav.org/troubleshooting/page-not-found

I have visited that page and checked things out…

The issue occurs even though I have my .htaccess file there, regardless of whether the RewriteBase is commented out or not. I also have AllowOverride in the Apache configuration set to All.

If I change permissions so pages aren’t writeable, for example with chmod 755, and go to my site’s home page, I get the grav error page telling me which pages need to be writeable. If I fix those with chmod 775, when I reload the home page I am immediately redirected to /admin which gives the error. Is the admin plugin trying to do some sort of configuration right away?

As a follow up, when I remove the admin plugin with bin/gpm uninstall admin, the main page loads fine. But reinstalling leads back to the same issue (immediate redirect to /admin with a 404).

The symptoms you are describing are classing rewrite issues. That ‘404 Page Not Found’ document that @flaviocopes linked to solves 99% of all of these issues.

If you hop on Gitter.im tomorrow i’m sure myself or someone else can help you with your issues. We’ve done this a lot!

The admin is trying to get you to setup an admin user. That’s all.

Ok, given what you said about setting up an admin user, I was able to create an admin user with bin/plugin login new-user and am able to load the home page fine. However, now browsing to /admin gives a 404 as well.

Yup, rewrite problems :slight_smile:

You will also have a problem if you create a new page and try to navigate to it.

Ok, I’ll take this issue over to gitter.