Admin Plugin errors when installed with xcorporation skeleton

Hi, I installed and successfully ran the X Corporation skeleton. I find no instructions for Admin installation for Windows users, so I followed the manual directions that explicitly say that I must download all four master plugins: admin, login, email and form. These were copied into the \user\plugins directory as instructed. The system now crashes on initial access with this message: [Pimple \ Exception \ UnknownIdentifierException Identifier “accounts” is not defined.] Same results if I only install Admin and Login and leave the origional copies for email and form. What to do?

Hi @gravitode, the steps you describe are correct. I just tried to install the Admin in the same skeleton (Mac) and got the same error. Perhaps post an issue on the skeleton’s GitHub repo?

It looks like that skeleton has not been updated in a while so it might be out of sync with the most recent Grav Plugin releases etc.

My hunch was correct, I used the Command Line Interface to first update the skeleton to the most recent version of Grav and then was able to install the Admin Panel without a hitch.

To save you some work, here is a ZIP file with the skeleton and the Admin Panel as a ZIP file:

Please let me know if this works for you.

Thanks, Paul for a quick response and a tested set of files. That’s great! I will give it a try tomorrow. Grav in general seems to be really buggy. I have wrestled with multiple issues in the two days that I have tried to configure it, so I am at the point of looking at other CMS. Your update would be an excellent update for the skeletons page.

Hi again Paul,

Actually I was curious so I tried it now. It fails. New error message.

The directory “/cache/doctrine/bfa9238b” does not exist and could not be created.

I omitted the path I am using to get to the website folders for readability. I am using a current version of MAMP for Apache. I just spent some time with Typesetter CMS and I think that’s the direction I will go.

Again, thanks for the effort to seek a solution. I think Grav just does not work well with Windows.


Your welcome, sorry to hear you had more issues re: Windows. Re: your shared error message often after an update the Cache needs to be cleared in Grav (in the Admin Panel Dashboard look for the “Clear Cache” button).

Good luck with finding a CMS for your needs!