Theme blueprints not working

Following this example:

I created my video.yaml file under “user/themes/MYTHEMENAME/blueprints”, contents of its file:

title: Video
    type: default
    context: blueprints://pages

      type: tabs
      active: 1

          type: tab
          title: Gallery

              type: text
              label: Add a number
              default: 5
                required: true
                type: int

              type: select
              label: Select one of the following
              default: one
                one: One
                two: Two
                three: Three

Cleared all caches, but i still don’t see that tab under “/admin/pages” or “/admin/pages/home” advanced tab. What’s wrong? Is it bug?


I have copy/paste your code in a new video.yaml on my configuration and i see the new tab.

So your yaml is correct.

Have you got some more information ?

Just strange, maybe issues with my theme’s yaml?

Here’s the contents of it (user/themes/MYTHEMENAME/MYTHEMENAME.yaml):

enabled: true
  enabled: true

Also is it possible to put my custom fields directly in “Content” tab?

Why it’s so complicated about blueprints in grav? I’ve tried a new installation of GRAV with default theme, IT JUST DOESN’T WORKS! Makes me mad.

could you describe the steps you did? I just tried clean installation of woo theme again, installed admin plugin, created “user/themes/mytheme/blueprints/page.yaml”, added yaml code from example, went to admin and nothing!

I don’t know woo theme.
What’s the content of your page.yaml ? Why do you need to create a page.yaml ?

Try first to create a page which template is default :

page.yaml has content just like in the first post.

Already have default page.