Modular blueprints only work sometimes

Hello! I’m creating a theme for a one-page site, and using a modular approach. I’ve been able to successfully create blueprints for two of the modules, but the blueprints are not working for the other 4. All the modules are set up exactly the same, and I’ve been trying to use the blueprint examples from the documentation (Example: Page Blueprints | Grav Documentation), which worked for the first two pages.

I don’t understand why it works for two of them but not the rest. I’m at my wit’s end. Any help would be appreciated.

The yaml:

title: Gallery
    type: default
    context: blueprints://pages

      type: tabs
      active: 1

          type: tab
          title: Gallery

              type: text
              label: Add a number
              default: 5
                required: true
                type: int

              type: select
              label: Select one of the following
              default: one
                one: One
                two: Two
                three: Three

File structure:


but the blueprints are not working for the other 4

“not working” is bit vague to test…

Anyway, you may try $ bin/grav cache. It does miracles sometimes.

Good point on the vagueness… the changes on the blueprints were not reflected on the admin page.

But clearing the cache worked! Been spinning my wheels for a couple of hours. Thank you so much!

@gcasalett, Add $ bin/grav cache to your toolbelt and use it whenever changes do not show up.

1 Like