Site.yaml redirect, but I get a browser error: The page is not redirecting properly

I want to redirect the website root to productos (products) page: 01.productos is the blog directory renamed, If I place in site.yaml this

  '/': 'productos'

In the url I get:

Please note that the added “es” is the language Spanish. I do not understand what is going on, I tried several other ways but does not work.

This is the browser error:

The page is not redirecting properly
Firefox detected that the server is redirecting the request for this address in a way that will never complete.
This problem may be happening due to having disabled cookies.

I am using Quark skeleton 2.0.0 and Grav and plugins are upgraded to latest versions.
Any Idea?
Thanks and regards

@joejac, If you want page /user/pages/01.productos to be the home page, you should set the following in /user/config/system.yaml:

  alias: '/productos'

and remove the redirect in /user/config/site.yaml.

1 Like

Thanks a lot @pamtbaau , it works now.
I used

  alias:  '/productos'

but I mistakenly placed in site.yaml sorry :see_no_evil:

One last thing on this issue @pamtbaau
I had to use the redirection trick because when I renamed the main page of Quark skeleton with 01.productos the website lost the home, when I entered the website it gave me “Error 404” for the entrance page of the website, any Idea of what I missed in my changes or website configuration?
Thanks and regards

@joejac, Have you tried $ bin/grav cache?

Thanks @pamtbaau
After any change done, I always erase the cache via the Admin plugin > Dashboard >Clear cache >All cache, I do not use command line.

  1. So this time I deleted the alias from user/config/system.yaml and saved without it:
  alias: '/productos'
  1. Then I cleared cache with the command line instruction:
    bin/grav cache

3. But same problem, please see attached screen capture

4. Directory structure:

5. Contents of user/pages/01.productos/

title: Home
    changefreq: monthly
body_classes: 'header-dark header-transparent'
custom: 'new thing'
blog_url: /productos
show_sidebar: false
show_breadcrumbs: true
show_pagination: true
       - '@taxonomy.productos': aceites
       - '@taxonomy.productos': filtros
        by: custom
          - aceites
          - filtros
    pagination: true
    url_taxonomy_filters: true
    description: 'Aeites y Repuestos'
    limit: 10
media_order: 'image-1.jpg,image-2.jpg,image-3.jpg'
        image: image-1.jpg
        heading: 'Tecnologia en <strong>ACEITES</strong>'
        subheading: 'Todas las Industrias'
        button_text: PRODUCTOS
        button_url: 'productos#start'
        image: image-2.jpg
        heading: 'Los mejores <strong>ACEITES</strong></span>'
        subheading: 'para <strong>DIESEL</strong>'
        button_text: DIESEL
        button_url: /diesel
        image: image-3.jpg
        heading: 'Tenga <strong>LOS MEJORES ACEITES</strong></span>'
        subheading: 'llame al <strong>Phone</strong> Ahora!'
        button_text: AUTOS
        button_url: /automoviles
        image: image-4.jpg
        heading: 'Productos de <strong>VANGUARDIA</strong></span>'
        subheading: 'llame al <strong>Phone</strong> Ahora!'
        button_text: MOTOS
        button_url: /motos
    slideMove: 1
    slider_type: text
    type_text_vertical_padding: 70px;
    type_text_horizontal_padding: 50px;
    mode: slide
    auto: 'true'
    loop: 'true'
    pager: 'true'
    controls: 'true'
    keyPress: 'true'
    pauseOnHover: 'true'
    adaptiveHeight: 'false'
    vertical: 'false'
    verticalHeight: 500
    thumbItem: 10
    gallery: 'false'
    galleryMargin: 5
    thumbMargin: 5
    enableTouch: 'true'
    enableDrag: 'true'
    pause: 5000
    speed: 1000
pagination: true

## Aceites y Repuestos

6. Templates not touched, I copied a modified Quark Skeleton from other web site, and the home page was working in this new website until I changed the name of the directory
Any more ideas or I go back to the alias? I would prefer to avoid tricks.

Thanks and best regards.


  1. So this time I deleted the alias from user/config/system.yaml and saved without it:

Don’t remove the home.alias: /productos. Without it, Grav will try to find the default page /home which does not exist on your system. Hence the 404.

Ok, you have given a bit more context info, but it’s still not clear to me what you are doing and when you get the 404.

Would you mind trying:

  • Copy your current Grav installation somewhere as backup
  • Create fresh install of the Blog skeleton
    • What is the path to the installation?
  • Rename /user/pages/ to /user/pages/01.productos
  • Set:
      alias: /productos
  • Without making any other changes, what do you do to get the 404?
1 Like

I am so sorry,

  1. I installed the original Quark Blog skeleton and it has in system.yaml in line 1
  alias: '/blog'
  1. I checked system.yaml in my previous installation that I used as base installation for the new oil website and that same 2 lines were in line 29 and 30 of system.yaml
  2. In the new oil installation I had it also in lines 31 and 32, that I did not noticed :see_no_evil::

For that reason it did not work when I renamed blog to productos.

  1. I also had a lot of extra stuff in the system.yaml that is not part of the original Quark system.yaml, so I used only the original Quark system.yaml and I only added the additional language section, I placed the correct alias only to /productos and now is working fine.

I am sorry for my confusion, and thanks a lot for your patience and guidance @pamtbaau

Best regards