Access Denied in Admin Panel

Hello, I’ve been playing with my first Grav setup but I ran into an issue with trying to log in to the admin panel.
I upgraded my grav instance to the lastest version(v1.0.0-rc.3) and then updated the admin plugins and the email, login, etc. as per the doc instructions. But now when i go the admin page after updating I get an “Access Denied…” message. Any simple fix for this?

*I created a user already, and have set up grav locally following your apache setup process:

Can i see a screenshot of that access denied message? Anything in your webserver logs?

Also did you ever have the admin working?

Screen Shot 2015-10-29 at 5

The admin panel had the login form, available before i created a user account and updated my grav version and the plugins.

I checked my apache logs, but i didnt see anything that strange myself. Any specific log i should check?

Ok, that’s a Grav config thing then, not an apache “access denied” screenshots are often more helpful than text :slight_smile:

So looks like your user yaml is not correct. If you look at your user/accounts/admin.yaml (or whatever your user is called), make sure it is in this format:

password: 'password'
email: ''
fullname: 'Johnny Appleseed'
title: 'Site Administrator'
    login: true
    super: true

The access portion is probably different in yours, and that is causing the problem.

More info here:

I created a user account following this setup guide. And this was generated output: Screen Shot 2015-10-29 at 5 *deleted the hash for screenshot

However now when i delete the user file, the admin page still shows an access denied message:
Screen Shot 2015-10-29 at 6

Can you try that file i provided?

Also can you double check that all the plugins did in fact update?

$ bin/gpm update --f

Copying your format for the user worked! So when you create a new user using gpm in the command line, is the structure incorrect? I dont understand why it wasnt working before. Thanks for all your help :slight_smile:

I’m not sure why it was not working for you. Works fine for me, and I guess most everyone else as this is the first I’ve heard of this problem.