Nothing shown after new upload

I changed our webpage to include the multi-langauage feature (using LangSwitcher plugin). Testing locally with Apache webserver was sucsessfull. To make sure that the homepage would work correctly,I uploaded the whole archive. It displays only a white page. Running on Chrome view source, admin or webalizer shows however, normal results. The provider cannot find a reasoneither. What could have gone wrong?

A blank page is always a error logged somewhere. turn on error reporting the maximum level in your php.ini, and check the PHP error logs.

Thanks, Flavio. I checked everything and could only find that the source code gets interrupted

The same site on the local server is:

So the difference in the

line is “/” vs. “/en”. is the website. Where did it get lost?



It probably halts on an error. Did you turn error reporting to max in the php.ini?

I found the issue and is related to the path for loading of images . I could correct this to some extent but havestill issues withthe blogmenu of the deliver theme. - How do you exactly maximize php.ini? Just copy and overwriting the development version? What error types should be turned on?

How can you generally make sure iff the site works locally, that it will also work on the server? The referencing of the base_url does not seem to be so straighforward after implementing multi-language. Wha thas to be considered to makea smooth transition?

Could this be permissions issues on the images folder?

already checked. and tested even with 777. It is really a path issues.

Here one example:

  1. Deliver:

  1. My modified version, running ok locally:
    <img src="/ 3693-dsc0020.jpeg"

Due to this image link the copied version on the web stops att the instruction before.

What could be the issue? The site is called and the image file can be accessed following this very link.

This is driving me nuts!

The blog.html.twig generateing the image link reads:

{% if base_url == base_url_relative %}
{% set feed_url = base_url~’/’~page.slug %}
{% endif %}

{% block content %}
{% set blog_image =|first %}

If I could set the php.ini to max, probably the issue could be detected other than a blank page.

ANother check: would yield a 404 page not found error. This is a correct route and still doesn’t work. Is it perhaps some group/user issue? Permissions were already set as recommenden (664, 755).

May change depending to how the hosting is set up. Check or ask the hosting provider support how to turn on error reporting.

Thanks, Flavio. I will try all this and let you guys know. Strange enough that this problem came up only after installing multi-language feature.