Meta description tag is empty after editing from the admin config


#1

Hi,

This topic is raised more often, but i don’t find any solution. After editing the default meta tag from the admin config settings (that showed up fine in the header before editing), it now shows up empty. I’ve seen this before and solved it by editing the twig file. I think it has to do with the child theme setup (for x-corporation).

This is the input:


This the output:
< meta name= " description " >

Can someone tell me which twig file to look at?


#2

@aristotletalks First of all, Windows 10 detects a virus in the ‘x-corporation’ skeleton…

Second: When using Quark and entering meta data in Admin for page on tab ‘Options’, section ‘Publishing’ all metadata appears correctly in the html page.


#3

Wait, is your anti-virus/firewall software giving a false positive? Cause mine sure isn’t and i did some checks and can’t find any possible virus/malware.
https://grav-theme-x-corporation.flatfiledeveloper.com/

And a site-wide meta description is a basic need, for example when you overlook a page in some certain scenario. But if it’s just related to my theme, i guess i’ll live with it, altho there are some pages like login pages that should have the basic meta description (cause well im not gonna change those, and even tho they’re not indexed i still want the basic description there).


#4

I have already notified the Grav team and the theme developer about the virus alert. It might be a false positive, but better save then sorry…

And yes you are right. I would not launch a website without at least a proper title and description.