Mediaembed plugin and youtube

Hi there (esp. sommerregen),

unfortunately I do have problems with the mediaembed plugin. I don’t know if it is a new user problem (I am a grav newbie, using it since one week).

Long story short:

  • I installed the one-page skeleton
  • I did the inheritance
  • and I made my changes in my new folder.

regarding plugins I only installed the

  • error (default)
  • problems (default)
  • mediaembed
    though I cannot get the bin/gpm running (which is another problem) I “installed it” manually, which means I copyed it into the user/plugins/ folder and did nothing.

I would have to have a video on the modular “highlights” page, which means I did this:

title: Homepage Highlights
menu: Produkte

That's all I did. I tried different changes in the mediaembed.yaml, also I tried to do a mediaembed.yaml in a user/config/plugins folder.

All I get (now, i updated the plugin 10 Minutes ago via github) is a pure link written down on the highlight page.

What do I do wrong? :-D

Thanks in advance


In addition:
Now I found out, when I click the link which is shown, I get a window, where only the youtube video is shown. Nothing else.

I am lost.

Hi Andreas,

first welcome to the Grav community! Second there is no difference, whether you install a plugin via bin/gpm or manually (I also install plugins manually :wink: ). If you copied all contents into user/plugins/mediaembed then everything should working.

First, to ensure MediaEmbed works correctly always prepend your links with the http:// or https:// protocol e.g.


instead of


It would be good to know by the way, whether



I don’t know why only a link appears. It should be something like the following in the screenshot MediaEmbed . But unfortatelly I can not reproduce your issue. Can you provide me with more informations? (a minimal working example of your file would be fine and maybe the changes you have made in mediaembed.yaml)

P.S.: Due to holidays here in Germany, I will be away from keaboard for the next two days. When I’m at home again I will answer you as soon as possible. Until then I wish you all the best.

Here is my
Regarding mediaembed.yaml I didn’t changed anything when I tested it the last time. So it is the original from your github repository.

Best regards from Berlin :slight_smile:

Okay here are some news.

I installed a fresh clean and basic grav package, which I downloaded from the site a minute ago. After uploading to my webspace, I directly installed the mediaembed-plugin by uploading and renaming it to mediaembed.

Same problem. I copied and pasted your link here

and also

all I get is a link.

Here is a screenshot.

Bildschirmfoto 2015-05-04 um 21

Latest news.
I tried the new plugin embed and that works. It is not so comfortable as I wished mediaembed would be, but for simple needs it fits. Yet.

Hi Andreas,

thanks for the news and sorry that the plugin don’t wokr. I will have a look and fix the issue. For the meantime as you already did (but as a recommendation for others experiencing the same problem) use the Embed plugin. I will keep you updated and have it hopefully fixed tomorrow.

Best regards from Tuebingen, although it wasn’t a long time ago that I lived in Berlin :wink:

I checked it against the latest release and it’s working on my local machine. Thus, I suspect there is something machine specific. If you are on Gitter tomorrow we can talk and try to figure out the issue together. The best time would be around 8pm (local time in Germany).

Thank you very much. I am awaiting news from your plugin. And I will try to be on gitter at eight :slight_smile:

Ok, see you then!

I am wondering if it is an hoster problem, but could that be?

Maybe not, it seems that MediaEmbed doesn’t recognize the link as such. As a fallback the plugin renders a link instead. See source in classes/MediaEmbed.php round line 187 (the service match doesn’t trigger in your case…, thus it will render a link in line 235).

okay let’s talk tomorrow. If you need anything from my side, tell me :slight_smile:

It seems that I am to stupid to use gitter :-/

Okay. I try to figure it out. But it is really difficult to find out, since even if I download the plugin from GitHub and install it manually your above links work… However, on what operating system are you using Grav?

you should have got mail :wink: