Login issue on admin panel


there is a bug where that if you are logged in and you flush cache data it will cause your account to be logged out by force and when you try and login again it just says “Invalid Security Token” i have cleared cache, cookies and so on but nothing fixes it. Also this problem seems to only occur on web browser safari on macs :confused: so i hope a fix can be provided since now i cannot use safari anymore on my grav due to it throwing “Invalid Security Token” every time up on login try.


I can’t replicate this, how are you clearing cache? I can clear cache no problem in the admin without it force-logging-me-out.

well when i added user manager plugin i added a friend to system so when he logged in and did some edits to some plugins and then he flushed the cache, all of it that’s when it kicked me out of from my account and said “Invalid Security Token” so now i can’t get rid of that problem :frowning: so when i then tried to login to my account through chrome it told me login was invalid so something corrupted my password. I managed to get login to work on my account by updating new password on it through my friends account and then i could login again, only on chrome works. but safari is stil throwing usual error.

I’m pretty sure its related to the user-manager plugin specifically then as I can’t replicate it. Please create an issue on that github repo.

okay, I have submited this on their github but if he tells me issue is within grav then i will get back to you here.

Hi, I have a similar issue. I have a recent install of GRAV (GRAV + admin). I installed the LEARN2 theme.
No other plugins, no user-manager plugin.
I did everything under Edge.
I added some pages + pictures.
After 1-2 days I flushed the cache and was logged out. Since then I cannot login in admin under Edge.
I use now EI to log in admin and add pages.
Same Security warning as JakeSully

Have you tried another browser to rule out if the problem is Edge only? I’ve tested with Edge in the past and it seems to work ok for me, but i don’t test it much.

The issue seems to be with Edge only. I could log in admin with EI and Chrome.
One curious thing though: the issue happened one week ago. Since then I tried once in a while to log to admin using Edge, without success. So I had to use EI to reach the admin. But since yesterday I can again log into admin with Edge and everything is working fine.
Is this cache related ? I haven’t flush the cache since one week.

Shouldn’t be cache related as the cache is disabled in the admin. It’s more likely related to sessions. Please create an issue on admin issue tracker if it happens again, https://github.com/getgrav/grav-plugin-admin/issues

See, i have also faced a simillar issue. Even after clearing the cache i cant login. I use the safari browser on my MACOS. I thought maybe safari can’t verify the identity of the website. So what should i do now??

I just had the same issue here, but the login page just kept reloading after entering the login data.
After removing the user/config/system.yaml I could login
So after some investigation my issue was
session: secure: true
That setting worked perfectly on my webspace, but not on my local mamp.
Missing SSL was the reaseon, so when you run grav via http, set secure to false :slight_smile: