500 Error Every Time I try to Install/Create User

Hi Everyone!

I’m trying to install Grav for the first time and continuously get a 500 error when I enter my URL into my browser.

I should probably preface this by saying I’m not a professional developer. I’m a hobbyist web designer who’s only ever designed her own personal website. I was sick of WordPress (far too needlessly bulky and slow) and wanted to give Grav a try. With that said, my web development knowledge is mainly coding HTML and CSS, very basic understanding of PHP (to theme), and uploading files via FTP.

I say all this because I’ve searched my issue – whenever I attempt to install, I get a 500 error – the answers are a tad confusing. I REALLY want to start using Grav, though. So I’m willing to learn if I can get this working.

So, here’s what I did:

  • I downloaded the Core + Admin version of Grav.
  • Unzipped it on my computer.
  • Uploaded the directory’s content directly to my public_html directory using FileZilla.
  • Then entered in my domain name to install/create the first user.

But I got this error.

I thought maybe the issue was that I was meant to install the core & admin in the grav-admin directory (I installed the files directly to my root folder so I jusy went to noelledevoe.com – my website – to install). So, I tried uploading again. Went to noelledevoe.com/grav-admin, and got the same error.

As you can see, the page doesn’t give me any details about what went wrong, so I’m flying blind here.

Could anyone give me some guidance/advice to figure out what’s going wrong here?


Just wanted to add that although I replaced my main index with a static page, noelledevoe.com/grav-admin still produces this error.

Thanks in advance in advance to anyone who can point me in the rtight direction, haha.

I get this error at times after a new install and or updates to theme/plugins. It is possibly folder(s) permission. Grav needs write permission for these folders.


I did’t read the rest of the post that you can’t access http://noelledevoe.com/grav-admin

Thanks @duceduc.

Just changed permissions for all those folders to 777, but the issue persists.

Thank you for that, though! If you have any other thoughts, def let me know!

I’ve also now tried most of the fixes on this troubleshooting page: https://learn.getgrav.org/troubleshooting/internal-server-error

  • Made sure I’m running PHP 5.6.
  • Checked My PHP.ini file and “register_global = On” isn’t in it to begin with.
  • Commented out “#Options -Indexes” in htaccess file

Problem is still persisting. So I think it could be permissions? In the past, to change file permissions, I usually just do it through FTP. Can anyone tell me what files/folders I need to make sure are writable?

Thank you so much in advance. Really hoping I can get this working.

Seems like you got it working now? I can view both of these links.
http://noelledevoe.com/grav-admin [frontend]
http://noelledevoe.com/grav-admin/admin [backend]

1 Like

Yes, I jumped into the Slack support forum and they helped me solve the issue there. Thank you so much for your help!

Cool. Do remember to change the /admin for security. The file you are looking for is in the admin plugin

route: ‘/admin’ <—change this

Good point. I will definitely update that. Thank you!