500 error after upgrading to v1.6.9 PHP7.2.18

Hi guys,
I thought I attempt the upgrade to the latest Grav version 1.6.9 running PHP 7.2.18 - but seems something went a bit off rail.
The previous Grav version I used was a 1.5.x. running already on the PHP 7.2.18 environment - no issues blazingly fast.
After the upgrade downloaded and installed (successfully) + all plugins updated automatically as well, I get 500 error on any front page example here: http://concretechone.samuellarcher.com.au/
I can however access the admin http://concretechone.samuellarcher.com.au/admin and in the backend all seems fine runnning the latets version however I noticed the backend pages load extremly slow - 10 seconds per page. I can save entries / settings.

I any ideas?

Also noticed these timestamp issues on the dashboard. Connected?

Hi guys,

fixed it - don’t ask me how : )

Bottom line: I replicated the upgrade process on my local environment using MAMP Pro. On the local environment the process went fine.

I then uploaded the site running v1.6.9 to my remote account and it kind of worked - pages still appeared broken. The grav error log flagged a permission problem with the index.php file - which was not 664. However that didd not fix the site entirely either.

I then updated the php ini file (by updating a rule - max_upload_size) which resolved all the issues.

So, I believe this was a mixed bag of issues with incorrect permissions and the freshly installed php 7.2 version not being setup entirely correctly.

Hope this might help someone in future.