I love this cms but i can't installed in ubuntu

Hi everyone.i try to install grav cms.after download a package+admin from website i make it in lampp/htdocs/grave, so i watch many errors. wedont khnew whatis is the problem

Grav this is home page in localhost:

I’ve installed it many times on Ubuntu in my testing… Just follow one of these VPS guides.

This one outlines how to setup a DigitalOcean VPS with Ubuntu and Nginx, but after you setup the VPS itself, the same guide applies to any Ubuntu installation.

You can also change out Nginx for Apache, but frankly Nginx is going to be faster :slight_smile:

BTW, your screenshot looks like a bad PHP setup.

I installed grav on Linux Mint 17.3 64 bit, an Ubuntu derivate. I did not install any LAMP packet. I installed just the packets as indicated in the grav website under https://learn.getgrav.org/basics/requirements.
Install Apache:

sudo apt-get install apache2

Enable mod_rewrite Apache module:

sudo a2enmod rewrite

Change Apache user and group (www-data) to my own user (example: “myuser”):
Edit /etc/apache2/envvars:
#export APACHE_RUN_USER=www-data
export APACHE_RUN_USER=myuser
#export APACHE_RUN_GROUP=www-data
export APACHE_RUN_GROUP=myuser

Install PHP:

sudo apt-get install php5 libapache2-mod-php5 php5-gd php5-curl php5-cli

Set the user rights properly:

sudo chown -R myuser:myuser /var/www/html

Install grav:
follow accurate the indications as in https://learn.getgrav.org/basics/installation. I took Option 1: Install from ZIP package.
Copy the unzipped directory to /var/www/html, e.g. /var/www/html/grav/.
If problems appear, refer to Ref. https://learn.getgrav.org/troubleshooting/page-not-found.
AllowOverride Allissue:
Edit the file /etc/apache2/apache2.conf:

<Directory /var/www/>
	Options Indexes FollowSymLinks
#	AllowOverride None <=== change to "All"!
	AllowOverride All
	Require all granted

RewriteBase issue:
Edit /var/www/html/grav/.htaccess:

RewriteBase / <=== uncomment and set it to the grav installation relative directory

RewriteBase /grav/

Stop and start Apache: submit this commands in the terminal:

/etc/init.d/apache2 stop
/etc/init.d/apache2 start

Remark 1: the files mentioned above shall be edited with sudo
Remark 2: the GRAV package with the Admin Plug in did not work for me. Therefore I opted to install the core package.
You’re done, good luck!