Need help completing install on Apache

My Grav install is here:

DigitalOcean VPS Ubuntu 16.04.
I installed Apache2, PHP7.0, etc.
Enabled mod rewrite.
Enabled sudo commands to Grav user.
Downloaded latest Grav to /www.
Unzipped and moved to /html
Installed admin plugin.
Restarted Apache

So, where have I messed up here?

Please explain any suggestions like I’m a trained monkey, because that’s exactly my grasp of most of this stuff! :slight_smile:

Did you follow the steps from the DigitalOcean VPS Guide?

Yeah, that’s the guide I was following, but obviously I missed something somewhere. Also, I kept Apache instead of installing Nginx, so I’m guessing that’s where I messed up.

I created a second Droplet and tried again. Same result.

Dumb question time: am I supposed to be running a particular file in the /html directory to initiate the admin setup wizard?

Ok, I just created a brand new base Ubuntu 16.04 droplet at:

Unfortunately, I have the exact same result :frowning:

Here are the exact steps I did. after logging in as root:

adduser grav

visudo (added grav user to have sudo privs)

logged out admin

logged in grav user

sudo apt update

sudo apt upgrade

sudo apt install apache2 zip unzip git php7.0-fpm php7.0-cli php7.0-gd php7.0-curl php7.0-mbstring php7.0-zip php-apcu

sudo a2enmod rewrite

sudo service apache2 restart

cd /var/www/html

sudo rm index.html

cd …

sudo wget

sudo unzip

sudo mv grav html

sudo service apache2 restart

I’m dyin’ over here. Any help offered would be greatly appreciated.

Forgot to mention I also installed the grav admin plugin after moving it to the /html directory.

This is so easy on MAMP, but I am stumped here on this VPS.

Any thoughts?

Can someone make a quick Apache install guide?

Did you change the user/group in httpd.conf like it’s changed in the nginx.conf ?

Is that the conf file in the /apache2/sites-available folder?

If so, where abouts do i paste the text, and am i supposed to paste exactly as seen on the guide or am i supposed to make changes?

Ok I gave up on the Apache install and followed the Nginx tutorial (DigitalOcean). I think everything went (mostly) fine but am seeing a “PHP XML Library is not installed” error when visiting my site for the first time, as seen at:

Any idea how to correct this? Grav is installed on a Ubuntu 16.04.1 x64 Droplet.

Got it figured out. I did some Googling and found I needed to run the following command:

apt install php7.0-xml