How to avoid 'Crikey!' error messages showing config details

Hi all,
from time to time it appears that my site does not work due to some files I’ve edited wrong. Then Grav shows the ‘Crikey’ error page with all my site details :frowning: I’d like to avoid that. I’ve read here that I could create a file ‘user/config/plugins/problems.yaml’ and just set ‘enabled: false’. I’ve done it but it had no effect.
So how could I display a nicer error message, especially which hides all my server configuration details?
Many thanks!

You can edit the error core file as well and delete what you don’t want to show. This will put the ownership of the change on you and will be overwritten during upgrades.

The file (or files) should be here:

If you are talking about simply turning off the detailed errors, the simplest solution is to turn off the errors display in system.yaml:

  display: false   

This will show a much less detailed error message.

@DarryllD, thanks for the details, but I’m sure I forget to reactivate as soon as I update Grav :slight_smile:
@rhukster, thanks, that’s easy. Updated system.yaml in user/config now.