Grav v0.9.6 released

Bugs or problems fixed? In that case, perfect^^

just some bugs fixed. Nothing huge, but some stuff that came up in these forums over the past week. A worthy update though. Grav is getting pretty stable now…

That’s perfect! Hope Grav go far!

One question: How can I update Grav from a Windows PC if I just uploaded Grav via FTP?

You can still do it on a windows machine, you just need to make sure you can use PHP on the command line. Have a look at this blog post

I wonder how I can upgrade from osx? I used the osx terminal (surely not the one that I’m supposed to use) but when I connect to the ftp account, navigate to the grav folder and enter bin/gpm upgrade it tells me invalid command… what programs can I use on osx? (as you noticed - real beginner here!)

You can’t use FTP/SFTP to run these kinds of commands, you need to SSH to your server.

As a beginner, I suggest you read over the 2-part tutorial I published yesterday on the blog. The first part is more about your local server, but the second part covers the remote server.

The gist of the tutorials is that you should be developing locally and limiting interaction with your remote live server as much as possible. This is just smart web development practice.

Actually, sorry for spamming… I managed to access ssh via the terminal app in osx by using ssh username@ipnumber. However, after navigating to the grav folder I get permission denied.
But no worries, thanks for the fast reply and I’ll look at the link you sent and figure it out somehow, else, I mean, reinstalling grav from scratch isn’t a big job (as long as I save the pages folder).

I 'm getting this:

Preparing to upgrade to v0.9.6..
  |- Downloading upgrade [1.27M]...     0%

Error while trying to download ''

when i run bin/gpm selfupgrade. (Although i can read the changelog before that)
Any ideas? (Windows 7 / php 5.4.16)

PS. Same problem with bin/gpm install

Hmm… the file looks totally correct. I copy-pasted it into a browser and it downloaded fine. Also just tested a 0.9.5 upgrade and it worked fine on my Mac.

I don’t suppose you have access to a php error log? Maybe there is something that is not 100% compatible with Windows, or your version of PHP.

Ok problem solved.
I had to enable the openssl extension… :*

Was just going to say that! I will make sure to update the learn docs to reference this.