You are running PHP 5.4.45, but Grav needs at least PHP 5.5.9 to run

Hi, when I run:

[~/public_html/gravtest]# bin/gpm index

I get:

You are running PHP 5.4.45, but Grav needs at least PHP 5.5.9 to run.

Yet I have confirmed with my hosting company that I am running
PHP Version 5.6.27

And this is also reported by gravtest/info.php

Help please

The problem is you are not running PHP 5.5+ in the CLI… Try:

> php -v

This will tell you which PHP you are running for things such as bin/gpm. You probably will need to contact your hosting provider to ask them where a newer PHP is located on the server. They can probably also help you add that new path to your account’s path configuration so it will get picked up rather than the default version.


PS you were right - when I checked using php -v it told me I have php 5.4

I had already contacted them twice to set it to php 5.6 and they said they had but obviously that is not the case…


If I run info.php in the folder that Grav is in, then I am told I have PHP version 5.6.27

However, if I run php -v on the command line in the same folder, I get
PHP 5.4.45 (cli) (built: Oct 5 2015 15:35:12)

My hosting company (a biggie, reptilian like) does not seem to have the abililty to resolve this.

Any help would be welcome.

PS Grav itself is running fine…meaning it is seeing PHP 5.5.9 or higher I would think???

Your default php version is 5.4.45. Your Hoster might have changed the php version your vhost/site runs on to 5.6.27 or whatever, but your default version still is 5.4.
You have to prefix bin/gpm with the path of the php 5.6.x executable.
E.g. on my CentOS VPS the default php version is 5.4.16, I installed php 7.1 via remi repo and I’m executing gpm like this:

/opt/remi/php71/root/bin/php bin/gpm

Of course you can alias the path or, like I did, make links in /usr/bin to be able to user this shorter command:

php71 bin/gpm

So, you’ll need the path of where php 5.6 is installed on your server to prefix the gpm command.

Thanks for your help hannesh!