Fresh install, first update: "NetworkError"

I have done a new install of the base + admin package and on the admin panel it tells me to update the packages. Doing so results in an error message that quickly fades away:

Screen Shot 2016-10-15 at 21

Everything seems to be fine after that, but of course I wonder what might be the reason for this message?

The files have the same owner as the webserver (apache2) is running as (www-data).

Looks like this same issue:

Do you have the same problem using Chrome?

Could be, but since 1.1.6 just came out, I can’t test it under the same circumstances anymore.

Just noticed that after upgrading to 1.1.6, the error happened again in Firefox when trying to upgrade the plugins.

Returned to a backup and tried again in Chrome, no error message.

Thanks for reporting, checking if I can replicate

I tried but I can’t replicate with Firefox. I guess it’s a GPM issue but I’m not 100% sure

I’m also having huge problems with GPM since upgrading to 1.1.6. I downloaded a skeleton that apparently still uses 1.1.5. When I tried using GPM to install the admin dash, it says I needed 1.1.6. Once I installed 1.1.6, GPM refuses to work anymore. If I run bin/gpm index -f I get the message No data was found in the GPM repository stored locally. If I try to run bin/gpm version I get the message [RuntimeException] Error while trying to download ‘URL to GRAV.JSON’ (didn’t use url because it seems to delete my post when I add a url). I’ve cleared the cache with no luck.

When I try running bin/gpm install admin after upgrading to version 1.1.6 I get the message [RuntimeException] GPM not reachable. Please check your internet connection or check the Grav site is reachable. GPM seems to work fine in 1.1.5. If I use GPM in a 1.1.5 project it works up until I upgrade to 1.1.6. I suppose I’m going to manually install admin but wondering what else is going on with this.

We’re going to push a fix for this very soon… Problem is GitHub is down due to this massive internet DOS attack.

@rhukster i change my dns from

and i have access again to Github

This is still an issue, is there an ETA on the fix?

@clayer still an issue with Grav 1.1.8?

Do I have to manually update from 1.1.5 to 1.1.8? Because bin/gpm selfupgrade still does not seem to work. - macOS Sierra running PHP 5.6.25

So I just tested the cli with a fresh and clean 1.1.8 installation. It does not work. Am I missing something?

Alright found the issue: I have to set gpm: verify_peer: false to get a fresh grav installation working on macOS Sierra. But my current projects are still on 1.1.5. Guess I have to update them manually…

The problem seems PHP to be using an old version of SSL, so Grav cannot communicate to the GPM server.

So I guess you need to manually update it (overwriting the bin and system folders should do the job)

Thank you! I updated already after writing this post and it works for me now. But still have to set verify_peer: falsethough…

The problem with verify_peer is an invalid / missing SSL certificate on your end. So by turning it off, you’re bypassing this check.