Error Upgrading to Grav 1.1.2 in admin panel

Hi, I’ve upgraded grav a couple of times and upgraded a couple of plugins today just fine. I tried to update grav to 1.1.2 and got this error:

grav.CRITICAL: Argument 1 passed to Grav\Plugin\Admin\Gpm::_downloadSelfupgrade() must be of the type array, null given, called in /home/ubuntu/workspace/csixtyfour/user/plugins/admin/classes/gpm.php on line 258 and defined

I think yo might of caught GPM during the updating process. I just tested and it upgraded fine.

Looks like it was a caching issue. I’ve just cleared the cache in the admin panel and it updated without any problems

Phew :slight_smile:

I had the same problem when upgrading one of my Grav installations last night (I also updated plugins at the same time). The install now seems to have worked but I get the following error whenever I load the main admin page:

Fetch Failed:
Cannot read property 'forEach' of undefined
TypeError: Cannot read property 'forEach' of undefined at t.value (http://[path to Grav]/user/plugins/admin/themes/grav/js/admin.min.js?d5f052cd07:4:2368 2) at http://[path to Grav]/user/plugins/admin/themes/grav/js/admin.min.js?d5f052cd07:4:2286 2 at http://[path to Grav]/user/plugins/admin/themes/grav/js/admin.min.js?d5f052cd07:4:2190 9
Invalid SSL certificate caused by CURL error number 60

This error pops in a red box in the admin then fades out. Everything appears to work ok. I’ve tried clearing cache in the admin but to no avail. My other Grav installs updated earlier today with no problem. Is there a fix?

(I don’t know if the SSL error is related.)

Problem understood: this install was on my local server, the error refers to the apparent inability to load news for the new News Feed box in the admin. Solved by going to user/plugins/admin/admin.yaml and setting dashboard-feed to false (thereby hiding the news feeds).