Error connecting to GPM

Hi everyone !
I’m new to Grav, and I can’t get GPM to run, either in the Admin or via CLI.
I checked what’s described in the Troubleshooting section of the documentation and a few issues already discussed here, but I can’t get it right.
cURL is enabled, as well as OpenSSL. My permissions look right. I tried disabling the Verify_peer setting.
I’m using MAMP on a Windows machine, with no special config.
I’m sorry I don’t know much about server config !
Thanks a lot for your time !

Are you running Grav 1.3.9?

If so, there was a bug found that made GPM not work and it is necessary to upgrade to 1.3.10. I ran into this earlier because the latest link downloaded 1.3.9 instead of 1.3.10.

Thanks a lot for your time and answer.
Yes, I was running 1.3.9. I downloaded 1.3.10, and now when I try php bin/gpm install devtools, I get an error

Preparing to install DevTools [v1.0.8]
  |- Downloading package...    error
  |  '- Error while trying to download (code: ):
  |  '-
  '- Installation failed or aborted.

Do you have an idea ?
Thanks again !

I’m assuming your server or dev environment is on a Linux install.

I would make sure you are su’d to the website’s owner or are running the commands from root as the owner rather than running them as root (if you are).

Warnings given and now put aside! Did you try the command given in this post?

 bin/gpm selfupgrade -f

I would try that; I would think it should work without the need for using php beforehand but it shouldn’t hurt. If not, I would check that your firewall allows outbound/inbound connections over ports 80/443. I utilize CSF on my server; its config can be found at /etc/csf/csf.conf. (You will need to determine what you are using otherwise. It could be UFW, iptables, APF, something else, or possibly nothing.)

I’m more of a SysAdmin than a developer; it could be an issue with the script, but I doubt that. I just ran it (1.3.10) and it connected fine. You could download the archive from Github and extract the necessary files and replace the source whole-hog, while excluding your user directory.

I can help with any of the server commands. Just need to know what you tried, what your system is running, and any errors you may be receiving!

Thanks for your answer.
I finally managed to get it right with your advice.
Thanks again for your time !