Error 500 on clean Digitalocean Server

Yes another error 500 post :*.
I cant for the life of me figure out what I did wrong…

These are the steps i took;

  1. Installed LAMP stack on Digitalocean server (using the pre-built from digitalocean)
  2. Enabled mod-rewrite using a2enmod rewrite
  3. Downloaded GRAV (no admin panel) and installed on server
  4. Error 500
  5. tried all the Error 500 fixes included in the troubleshooting
  6. Rewrite base is set to /other/grav //
  7. php error.log can be found here
  8. Permissions set to 664 and 775

If anyone can help me thank you! because i cant bloody figure it out and i really wanna use grav!

The error log is saying that your cache folder is not permissioned properly. Whatever user is running Grav also needs write access to the cache folder. Revisit the Permissions docs and double check that your user/group settings are correct. There’s also a specific Digitalocean page you can look at, too.

@Rhukster once recommended to me to setup a Digital Ocean server for Grav, which has basically allowed me to forget something called “permissions” exist.

Same problem on DO. That helped:
sudo chown -R www-data:www-data /var/www